Best Browser for Eupedia

In my experience, Microsoft Edge has the best responsiveness to the forum software. While currently Google Chrome has been the most problematic. Does anyone else have any insight in what they think is the best browser to use?

That's exactly my experience.

My tech guys keep telling me to exclusively use Edge, but I've gotten used to the Chrome features.
 
I admit that I never use Edge. I haven't noticed any lack of responsiveness on the forum. Everything loads in a blink. I usually use Chrome or Brave (a deGoogled version of Chrome with higher privacy). If Chrome is slower it might be because of some plugins/extensions. The more you have, the slower it usually becomes. But it could be a single extension slowing it down.

I checked Google Analytics and the fastest PC browser in average for Eupedia is Firefox, followed by Chrome.

BrowserAvg. Page Load Time (sec)
1.Safari (in-app)2.37
2.Android Webview4.10
3.Firefox4.20
4.Chrome6.21
5.Edge8.14
6.Internet Explorer11.52
7.Safari11.63
 
I admit that I never use Edge. I haven't noticed any lack of responsiveness on the forum. Everything loads in a blink. I usually use Chrome or Brave (a deGoogled version of Chrome with higher privacy). If Chrome is slower it might be because of some plugins/extensions. The more you have, the slower it usually becomes. But it could be a single extension slowing it down.

I checked Google Analytics and the fastest PC browser in average for Eupedia is Firefox, followed by Chrome.

BrowserAvg. Page Load Time (sec)
1.Safari (in-app)2.37
2.Android Webview4.10
3.Firefox4.20
4.Chrome6.21
5.Edge8.14
6.Internet Explorer11.52
7.Safari11.63

Loading times are fine, it is just that with Chrome, I find that I am automatically signed-out from time, to time; or locked out for failed password attempts. But with Edge, I do not have that experience 95% of the time. However, the point you raised about plug-ins may have something to do with it. I have two from chrome (text-to-speech program, and screen capture), perhaps they are causing the issue.
 
Loading times are fine, it is just that with Chrome, I find that I am automatically signed-out from time, to time; or locked out for failed password attempts. But with Edge, I do not have that experience 95% of the time. However, the point you raised about plug-ins may have something to do with it. I have two from chrome (text-to-speech program, and screen capture), perhaps they are causing the issue.

I have the same problem with chrome, although I don't know why. At least once a day I get a message that I have already tried five times to log in and will be locked out for 15 minutes. I can go to Edge one second later and sign in. It's weird.
 
I have the same problem with chrome, although I don't know why. At least once a day I get a message that I have already tried five times to log in and will be locked out for 15 minutes. I can go to Edge one second later and sign in. It's weird.

Actually I have had that problem too with Chrome (only). Try Brave. Works just like Chrome, but without this bug.
 

This thread has been viewed 6268 times.

Back
Top